Post your Questions & Topics for tomorrow’s AFTVnewscast 66

I’ll be live streaming this week’s episode of the AFTVnewscast tomorrow at 11am PT / 2pm ET. Post your questions or topics in the comments below for me to answer and discuss during the episode. Anything goes for questions, whether it’s about the Fire TV, AFTVnews, or tech in general. Let’s hear them! Even if you can’t watch live, ask your question now and catch the episode on YouTube later.

  1. kel says:

    the apps not showing up in the app section how to you make them appear again..since the new update

  2. Jeck says:

    Not really Fire TV directly but do you have a favorite way to manage emulators within Kodi?

    I’ve been reading about Advanced Emulator Launcher and ROM Collection Browser so far.

  3. irshad says:

    Hi elias,

    Anyway to change sideloadable apps icon as they look quite bad in the recent menu on the home page. Like kodi for example


  4. Big John says:

    Is there a way to prevent an unrooted Fire TV Stick (1 and 2) from going to sleep? I’ve disabled the screensaver, but the sticks still go to sleep. I see nothing in the settings to address this. I’ve searched the InnerWebs and have seen mention of an app (Tasker) that apparently no long works on the updated OS. Thanks for any help in pointing me in the right direction.

  5. Arnold says:

    What are your thoughts on the apple tvs new TV app? It similar to what Fire TV does with search.

  6. Patsy O says:

    Hi Elias, Just wondered if you could help me with something please… I’ve been playing DeadTrigger2 on my rev 1 Firetv box v (unrooted) for ages, up until today, when i was met with a message “Please update your application with a new version”… I’ve already contacted Madfinger games, but I know they have dropped support for amazon devices. Do you think it would be possible to sideload DT2 from google playstore and carry on as normal. appreciate any help and also your time as I know your very busy with the site. Thanks… Pat.
    P.S> why oh why did amazon remove the prime banner icon from there prime movies…

    • Patsy O says:

      I managed to update DT2…. although I’m not sure how… but it was a combination of apps2fire on an android phone,… and installation of DT2 on the same phone.
      ES file explorer on the firetv. I noted down where the obb was located on the phone and the name of the folder.
      I created the same folder on the firetv.
      I then sent the main apk to the firetv. and ran it without the obb files.
      DT2 ran and said it needed to download a file of around 250mb. But this download failed with an error of “Download Failed Because The Resources Could Not Be Found”.
      SO I then sent the obb files from the phone to the firetv (this took ages).
      then using es file explorer and changing the icon display I found the obb file in a “Download” folder. I then copied and pasted this to the obb folder.
      This time when i ran DT2 it said it required files from the amazon app store, and would i like to download them,… i agreed to this.
      I then re-ran DT2 and the intro started to play. I skipped the first parts so that i could put in my own details.
      I then closed out of the app.
      I then noticed that DT2 stated that there was an update available, (I had already tried this but it failed, but i thought, what the hell and I’ll try it again)… this time it fully updated. The amazon controller still works perfectly,… and the new xmas theme is on the game. But the graphics look a lot better than the original version from amazon.

  7. DotWin says:

    I’m not happy about the new user interface:
    Yes, it looks prettier, but everything needs significantly more clicks to get to get to the stuff I use. Paid content is featured much more prominently, which is a bummer for people who only care about the Prime videos. The section “Movies recently added to Prime Vodeo” is missing (“TV Shows recently added to Prime Video” is still there), at least in Germany. Instead you get “Featured” and “Recommended” content everywhere which I hate. The integration of the new Amazon Music App and the App itself still suck.

    Nevertheless, I stumbled upon a strange “bug”:
    The new user interface is now on my Fire TV 4K for 4 days.
    In the App Store settings automatic App updates are enabled, as they always were.
    Yesterday evening I opened the section showing all my installed Apps (approx. 55).
    I checked each of them individually and for approx. 20 of there was an update available, but none of it was installed automatically, and so I started to update them manually one by one, but about 8 of the updates failed, so I had to uninstall these Apps completely first, and re-install them afterwards. The same behaviour occurred after restarting the Fire TV.

    Does anyone else have issues with automatic App updates?
    Did your Apps update automatically since the new user interface was installed?

    Thanks in advance!

  8. keldona says:

    With the official launch of Amazon prime video in Canada how long do you think it will be until we can buy fire tvs in Canada.

    Thanks love the pod,

  9. Phil says:

    Hi Elias, just updated firetv 2nd gen to pre rooted, no problems. I noticed in the notifications that supersu,the su binary needs updating. Should we update

  10. DoMay says:

    Hi Elias, I tried to install the newest rooted version, but whenever I enter TWRP and try to click right to prevent the FireTV from launching regularly, it does not work. I tried with my Logitech K400 plus, an old fashioned cable keyboard, the Fire TV remote control, a gamepad and even the Remote Fire TV app for Android ( I was desperate).

    All devices work normally after the FireTV has started, only in TWRP I get no reaction.

    Any idea where I could find a solution? THANKS!

  11. Alfredo says:

    Hey Elias. I notices that my kodi cuts playing off after 30 minutes or so. After I upgraded to Rbox 5240 any ideas why is doing.

  12. Mick says:

    Do you have a firetv 1 with Kodi 17 Beta?

    I have one with updating switched off since firetv OS 505, and since kodi 17 B3 I get long blank screen when switching in and out of Kodi to the firetv gui. My TV complains about loss of HDMI.

    I bought a firetv stick 2016 and no problems.

    I don’t know whether it’s the firetv 1 or the fireos 5.0.5 that causes the problem, I certainly don’t want to update the os unless absolutely necessary as then firestarter won’t work.
    Done the usual things like deleting and re installing kodi and removing firestarter.

  13. Juan says:

    I am having issues playing DirectvNow app even after hiding my root – When i tried to revert back it says cannot find su app. So how do i proceed ?
    Also what is the process to UNROOT my rooted Fire TV1( which i believe is using TWRP – The guide you have is for Clockwork MOD only. Plz advise.

  14. DeanR1977 says:

    Im not asking for a “when is this gonna be released question” but just asking its been sometime that the firestick was gonna be getting a recovery system? Has any progress been made with this since? Because the last time i looked (months & months ago) they were pretty close to doing this? Then a more stable root process would be accessible? Or is this process pretty much not happening no more? Thanks anyway

  15. Liam Burke says:

    Any idea when the Fire TV Stick 2 will be available in the UK?

Leave a Reply

Your email address will not be published. Required fields are marked *


Get AFTVnews articles in your inbox!

Get an email anytime a new article is published.
No Spam EVER and Cancel Anytime.