Post your Questions & Topics for tomorrow’s AFTVnewscast 48

I’ll be live streaming this week’s episode of the AFTVnewscast, at this link here, tomorrow at 1:30pm PT, as I do every Friday. Post your questions or topics in the comments below for me to answer and discuss during the episode. Anything goes for questions, whether it’s about the Fire TV, AFTVnews, or tech in general. Let’s hear them! Even if you can’t watch live, ask your question now and catch the episode on YouTube later.

  1. Robert Simandl says:

    For a while now, I’ve had a 1st-gen FTV in my family room and a 2nd-gen FTV in my bedroom. I just got a new 4K TV in the family room and of course want to switch the FTV’s now. It would be much easier to simply disconnect all cable from each FTV (including the power cords), just switch the boxes, and reconnect all the existing cables. Is there any harm in using a 1st-gen FTV power cord with a 2nd-gen FTV and vice versa? Thanks!

    • Robert Simandl says:

      Never mind, just noticed the connectors for those power cords aren’t even the same size, so even if the voltages are the same they physically can not be switched between 1st and 2nd gen FTV’s.

    • Ulises A. Rodriguez, Ph.D. says:

      As you have already noticed, the connectors for power cables are not even the same size, both are round but of different sizes!

      But most importantly, Volts and Amperes, are also totally difrentes:

      Amazon Fire TV (1st Generation Fire TV) Power Adapter
      Output 6.25 V DC-  2.50 A (16 Watts)

      Amazon Echo and Fire TV (2nd Generation Fire TV) Power Adapter
      Output 15.0 V DC-  1.4 A (21 Watts)

      From the above product description you may has noticed, that the Fire TV (2nd Gen.) Power Adapter and the Amazon Echo Power Adapter, both have same Voltage/Amperage and also same connector size…

      Maybe Amazon made these changes, not only for the FireTV (2nd Gen) had a more powerful adapter, but also change the size of the connectors to avoid confusion or damage to FireTV1, which uses a Power Adapter of lower voltage: 6.25 V.

      I really hope this information will help you clarify all doubts regarding the differences of these 2 Power Adapters!

    • Omar says:

      Different plug won’t fit and wattage too

  2. Philip says:

    Is the current version of fire tv 2 not rootable easily currently? If you want to rollback to an earlier version and then root, is this possible?



  3. Lodewijk (Lewis in english) says:

    Hi Elias,

    Finally I am back. Holiday’s, dinners, etc. on Friday’s.
    I love my sideclick, so does my wife. So nice to put the remote of the TV and of the AV receiver away.
    Got myself a amazon fire TV stick for the bedroom on prime day. Airplaying in the bedroom got too annoying.

    I see not too many questions so I will ask away.

    1. If I have a zip file for a Kodi add on (legal streams, don’t worry) on a USB, Can I just plug it in my AFTV and install like this inside Kodi? If not what would you say is the best way to install a add on zip file for Kodi that’s only available locally on PC/USB and you don’t have a NAS.

    2. I am thinking to buy a Rasberry Pi and build an amazon Echo. Do you know if you do this you will have the full functionality? Like there are some differences between Alexa on the TV and on the Echo (for me the WEMO that doesn’t work with the TV Alexa because it’s cloud based).

    3. Does kindle first also work with my amazon tablet? I don’t have a kindle.

    4. Do you think the next generation amazon fire TV will support HDR? I guess the next amazon fire TV will have HDMI 2.0 and possibly 60 frames per second 4K. What do you think?
    Do you expect this device end of this year or later?

    Thank and take care


  4. Jo says:

    My Video Library is becoming unwieldy. Is there a way to sort the videos alphabetically. You can sort it on your pc. But what about sorting content on your fire stick?

  5. DJ1 says:

    I am unable to install V1.5 Resflux apk on my rooted AFTV1 after installing Xposed to change my wallpaper setup.
    Failure [INSTALL_FAILED_UPDATE_INCOMPATIBLE] – Is it still possible to change the wallpaper on the new Fire OS 5 if so how.

  6. Wrecks says:

    Ever since the last update my FireTV2 has a problem. If I am watching video and my TV changes channels (usually because I accidentally hit one of the number buttons on the remote), when I return to the HDMI1 input the FireTV2 is not sending a video signal and it does not respond to any input from the remote. I have to pull the power and restart it to get it to work again.

    My FireTV1 does not do this. Am I the only one with this problem?

  7. jwmcg says:

    Since Flixster stopped working on Fire TV, I haven’t been able to find a Fire TV app for viewing UltraViolet movies. Are you aware of any Fire TV apps that will allow for viewing of UltraViolet content? Thanks!

  8. Luis says:

    I just Updated my rooted 1st gen firetv to the latest pre-Rooted rom everything works except my SSHdaemon host.
    The application still runs and can be configured but my winscp client nor filezilla can FTP, ssh or sftp into the device. Is there a way to bring this functionality back.

  9. John says:

    I stayed up through midnight for the start of Prime Day and saw you start posting deals. Then I went to sleep and woke up to see you posting more. Then I checked in mid day and again in the evening to find you still posting. You’re an animal! Did you get any sleep at all?

  10. Sammers says:

    The guide about removing ads on the Blu phone is interesting. Are you going to write more about that phone or start covering more phones in general?

  11. Omar says:

    I tried getting the Es file explorer that was modded that someone posted in comments and didn’t want to work from mega. Any chance someone can google drive link it somewhere

  12. IB says:


    Cannot root my Amazon fire stick os 5.2.1. Was referred to kingoroot by your link to this page which states this root process usually works on fire stick.

    1. tried to install KingoUser but it says it needs an update even though I downloaded the apk from the linked site. Clicking the update button gives error that browser must be installed? Installed Firefox but still says need a browser. What browser would install on a fire stick and make KingoRoot happy?

    2. Tried to install KingoRoot and after 10% get error message “unknown network error”. Tried following their trouble shooting guide for saving log file but there are no buttons or clickable areas on the install screen.

    3. Went to KingoRoot web site and re-downloaded APKs from there but still got same results as mentioned above.

    I have a lot of computer experience but none with android. Any help getting my firestick rooted is greatly appreciated.

    The ultimate goal is to get PIA VPN working on the stick. Everything I tried failed and web research points to the need for root.


    • IB says:

      I finally got my stick to root. I had to install kingoroot apk via ADBlink instead of ES File explorer.

      Any thoughts on why this is?


  13. GlammaGeek says:


    I am most curious about the ability to remote into a non-rooted AFTV and control it the way I can with a rooted AFTV. Currently, I use TeamViewer and it has served me very well on rooted devices. But, if I could control non-rooted devices as completely as I could rooted devices, well then…I’d be in heaven.

    If there is no work-around using TV, do you know of an alternate app which could accomplish complete remote control?

    • GlammaGeek says:

      Thanks for reading my question. You really should look into TeamViewer for remote control on a rooted Android device. It’s cool because I manage a lot of AFTV’s and being able to control them as though I’m sitting right in front of it is awesome.

  14. GlammaGeek says:

    Sorry. I also want to share my experience putting TWRP on an unlocked-bootloader AFTV 1st generation.

    In my experience, everything went well until it was time for the TWRP logo to show up after installing then booting into recovery. I kept thinking I was doing something wrong. So, I switched to a different television and noticed that the old rbox Comic Sans boot menu showed up. Then when I selected “Recovery” VOILA!!! TWRP was there and I was able to install the pre-rooted ROM.

    Since the instructions say this should not happen on a device with an unlocked bootloader, I just wanted to share my experience that it indeed does happen on an unlocked bootloader. But once you hit “Recovery” everything else works out just fine.

    If anyone else runs into the same problem, I think this info will prove most useful.

    Thanks to you and Rbox. I really love you guys and plan to buy you both a couple six-packs today.

  15. joe says:

    Hi I just got a refurbished fire stick my first one its got 5.0.4 on it so I unplugged it. Should I rrot it or just disable updates and if I do disable what ceatures will I miss iut with the newest updates? Thanks

  16. Fredrik Svensson says:

    Hi Elias,

    I bought an Amazon Fire TV for 3-4 weeks ago from Amazon via because I live in Sweden and Fire TVs is unfortunately not selling here yet.
    I tried directly sideloading Kodi via EZ File Explorer and ran into the problem you mention that you are unable to download an APK. Solved it by a USB memory and sideloded the way. My question is if you sideload an app will it be updated later if a new version come out or do I need to download and sideload the latest APK file and install it manually?

    Big creeds to you on webpage and especially pod / live cast :=) I do check out the live broadcast on Friday evening here at home in Sweden 22:30.

    • Fredrik Svensson says:

      Just want to point out that I always check your live stream via my chromecast, then one year back ago, because I have not got my hands on a Friday TV to now :P Always good stream for me from Sweden.

Leave a Reply

Your email address will not be published. Required fields are marked *


Get AFTVnews articles in your inbox!

Get an email anytime a new article is published.
No Spam EVER and Cancel Anytime.