Post your Questions & Topics for Tomorrow’s AFTVnewscast

I’ll be live streaming another episode of the AFTVnewscast tomorrow at 1:30pm PT, as I do every Friday. Post your questions or topics in the comments below for me to answer and discuss during the episode. Anything goes for questions, whether it’s about the Fire TV, AFTVnews, or tech in general. Even if you can’t watch live, ask your question now and catch the episode on YouTube later.

  1. DJ1 says:

    When will the rooting guide be ready for rbox’s method ?

    • Some One says:

      This is exactly what I wanted to know! I have been patiently waiting since Elias announced this news earlier in the month. I told myself that I’d ask this question when the first Friday of February comes. Coincidentally it was the first posted question…YES!!!

      If you don’t have an ETA. Then do you have any updates from yourself or rbox on the subject? There is little to no mention of this over on the XDA forums.

    • DeanR1977 says:

      It would be great for an release date (but I don’t like to ask) but as the words from Rbox himself on Xda it’s almost complete so expect some time very soon, I’d rather like to hear how he’s doing on the recovery & rom (if everything’s going to plan & without problems)

    • Y314K says:

      Dito. Not asking for an ETA. But I wonder if RBox has at least gotten his hands on the update file. Which would be the first step. Or how far along is he in the process.

  2. Robert Simandl says:

    Since the 2nd generation Fire TV’s can’t use the USB port for apps, will the 1st generation Fire TV’s with updated software not be able to, either?

  3. Sam says:

    The feature I want most is to be able to search only within the movies I’ve purchased from Amazon. I’ve tried adding “in my library” and other variations of that when I use voice search, but it doesn’t work. Is there a way to search just my library on the Fire TV? If not, is there a technical reason why it’s not possible because it seems like that would be an obvious feature to have?

  4. J-Fire says:

    whatever happened to fling?

  5. Ray says:

    Hi Elias

    Back once again (LOL) and I’ll probably chime in again via Twitter.

    Here’s this weeks questions:

    1. The issues I mentioned to you via email that I encountered with the WiiMote and WiiGame Pad, could they be to do with using an old Xposed framework?? What’s the most updated version?

    2. I’ve seen on XDA that FireOS 5.0.4 on the FTV has added extra support for the Xbox 360 wireless gamepad (I’m guessing thru the USB dongle); if that’s the case, I suppose that the same support should be added to the FTV1 with FireOS 5.0.5, right? Or is it at kernel level and being different SoC means different Kernel and therefore means different support instructions and implementations??

    3. I’ve seen a few people using ePSXe on the FTV and also the “droid” emulators (i.e. NesDroid, NeoDroid, etc) stating good results. Do you reckon it’s a possibility or would you call BS on their statements?? Or would you say it depends on ROM quality / GPU needs?

    Think that’s it.. anything else I’ll grab you on Twitter ;)

    Thanksnin advance

    • Some One says:

      I also would like to know the answers to Ray’s 2nd & 3rd question. Particularly the emulator related question! I’m an extremely avid retro gamer and that would damn near make the Fire TV a complete all in one solution for a lot of people.

  6. ben says:

    if you did the the preview thing will you still get the update

  7. shibu says:

    There’s no alexa on my fire tv box. i am in uk and that’s dissapointing. when will alexa come to uk? any inside news or updates


  8. Axecaster says:


    Is there a way to prevent Amazon from force-updating apps from their app store like there is in the Google Play Store settings? Or, maybe there is a way to freeze or disable the process on rooted boxes?

    I had backed up some older apk version files from months back. Recently, I uninstalled the current versions, restarted the box, then sideloaded the old versions. They still seemed work, but a day later, I found the apps had automatically updated. The differences in icons and/or functionality tipped me off to recheck the version numbers.

    Thanks in advance.

    • Y314K says:

      Go to Settings/Applications/Appstore and turn “Automatic Updates” to off.

      You can still manually update an app by going to Apps/Your Apps Library. Check your installed apps. Your looking for the ones with the extra option to “Update” under their icon. I always mark all my installed apps as “Favorite” so it’s easy to check for updates.

      • Axecaster says:

        Thank you (and Elias) for that reminder. For some reason, I wrongly assumed automatic updates were already set to off. In the past, I had seen manual update options on apps. Maybe clearing the appstore data reset those settings?

  9. Jim says:

    I have a question about rooting. So if ive updated to latest operating system do I still need to stop auto update on my end even if i plan to give the ftv2 to a friend of mines in a few weeks so he can root it himself OR should I update and then stop auto update on my end then give it to him in a few weeks?

    • DeanR1977 says:

      You can stop OTA updates via your device Or & your router, so if you stop OTA on the device that would be fine to pass the device on afterwards.

  10. Lodewijk (Lewis in english) says:

    Hi Elias,

    How are you doing?

    It seems you inspired Luke from the cordcuttingnews with his Q&A podcast ;)

    Where do you get the info about what will be new on Amazon/Netflix the next month?
    Is there a place where I can see the total content of amazon prime video?

    My 1st gen AFTV is not updated yet to OS5. Do you know what would be the latest mine will be updated (Guess I am late in the update cycle)? I can’t wait to play around with Alexa and control my home smart devices.

    Thanks and have a great weekend,


  11. Mark_Venture says:

    Having both 1st and 2nd Gen Fire TV’s in my house, I found some applications not available for one or the other. Like Watch ABC for example (available for the 1st gen, but not the 2nd gen). If its an OS limit, will the app “break” when my 1st Gen Fire TV gets upgraded to OS5?

  12. Eddy says:

    Silk Browser for Fire TV?

  13. fassfa says:

    What happened to the app that turned firetv’s into a Chromecast receiver? Are there other apps that can do the same thing?

  14. Y314K says:

    On the update guide for the Rooted 1st Gen FTV’s will there be updates for SuperSU, XPosed Framework & or any PlayStore or Google System apps/files that we install after Root.

    The reason why I ask is that for some of us the old SuperSU won’t open as an app after a reboot. You can only trigger it thru ADB or if an app request root access. I remember RBox mentioning something about it. But I wonder if once updated to 5.0.5 a newer version of SuperSU will run better.

    I guess I am asking if the upgrade guide will be full all parts updated guide or will it just be for the rom itself. I would like to keep root but update everything & do a Factory Reset since it’s a major update.

  15. Jeff Burkhardt says:

    Hi Elias,

    I love you Site & podcasts, they have really helped me to use and enjoy my fire TV. I know a thing or too about computers. Have been using IBM PC’s since DOS 2.10.

    Anyway I love your guides and finely have updated my FTV1 to the most current RBOX rooted ROM with your Guides(Worked Great). My problem is updating my AFT2. I am getting stuck on the MT6577 USB VCOM driver setup and install. My computer is running XP Pro and I have the Developer ADB options turned on. I cannot get the PC to talk to the AFT2 with the A/A USB cable, so I am stuck for the moment. I have went over RBOX guides to do this, My system will not install them and recognize the AFT2. Any help will be appreciated. Keep up the good work…


  16. Leonid Kisliuk says:


    I have Amazon Fire TV1 box , after installed KODI 16 Jarvis and Kingroot I have the problems to see video and TV. Problem is that after 20-25 min my video or TV program were closed (I tried from several add ones) and I need to open my video/TV again. I had before KODI 14 and it work without any problem (without Kingroot). Also in KODI 14 I had option continue watch from stopped place (not start a new watching as in the KODI 16).
    I received answer : Delete Kingroot and problem go away (from KODI forum). What is a good way to delete Kingroot. I tried to do it, but remote control and mouse didn’t work into Kingroot app. I can only push optimize button.Also I found Tutorial To Replace Kinguser With SuperSU. Is it work in AFTV?
    Please help me solve this problem.

Leave a Reply

Your email address will not be published. Required fields are marked *


Get AFTVnews articles in your inbox!

Get an email anytime a new article is published.
No Spam EVER and Cancel Anytime.