Fire TV Stick will not accept a USB Keyboard or Mouse

Now that we know the Fire TV Stick’s USB port is not just for power, I tried every way I could think of to get a USB keyboard or mouse to work with the device. You can see a sample of my test setup above with some of the OTG and non-OTG cables I tried without any success. I tried both with and without a powered USB hub with every cable and configuration. There was never a sign that the Fire TV Stick recognized a connected peripheral. This leads me to believe the Fre TV Stick kernel or OS is deliberately set to remain in USB slave mode and not enter USB host mode. For anyone interested, here are the cables/adapters I tired: included micro USB cable, OTG cable w/ power, Femnale / Male adapter, Sanoxy OTG Cable, StarTech OTG Cable, Generic OTG Cable, and various non-OTG cables I had.

  1. Icky_Thump says:

    They are really going out of their way to make sure the device is not used outside of the Amazon environment

  2. Y314K says:

    The only thing left to test is if someone owns a Nyko PlayPad Pro & it has the FireTV FW. Can someone try the BlueTooth connection & the Mouse mode to see if that works…

  3. Kanedo says:

    I am able to pair a BT keyboard and mouse via the side-loaded settings.apk

    This gives me same functionality as a USB keyboard and mouse once FireTV is booted.

    However, this solution isn’t ideal for bootmenu and CWM.

  4. AQKhan says:

    This is probably by design to prevent ultimately, the installation of CWM and alternates to FireOS. I wouldn’t put it past Amazon to do the same and strip out the ability to use USB keyboards and mice, for the FireTv as well, in the next update for that device.

  5. turbostick says:

    the setting apk is too dangerous to use. I accidently turned off my Bluetooth setting which break my tv stick with out a remote. Fortunately I have my adb debugging turn on.

    • Tim says:

      How, I had the same issue. Accidentally turned off the Bluetooth, can you let me know how to turn it on?

      • sunil pothireddy says:

        Even I had same issue….

        My solution….
        Install Fire App on any andriod smart phone and connect it to same wifi, then it acts as a remote
        Then Turn On Bluetooth :-)
        You should be all SET

        • leroy says:

          how do you get the fire stick to connect to the WiFi if your blue tooth setting is off can’t get the remote to work

          • Ujn Hunter says:

            Bluetooth & WiFi are two totally different things. They have nothing to do with each other.

          • xnamkcor says:

            Plug in a USB mouse long enough to navigate to the bluetooth settings. Did you accidentally turn it off?

          • xnamkcor says:

            Sorry, I just realised this is the Stick. It has no full-size USB. Maybe a factory reset would work? If you just happened to have Network Debug enabled, you might be able to send it commands via command line from a PC? Hold Home on the remote. I think most of the time that turned on bluetooth for me sometime? Try rebooting the device. It may check to see if it’s set on boot and correct if it isn’t.

  6. mito says:

    Has anyone tried to connect a usb hard disk or usb stick directly to the fire stick tv using an otg cable?

  7. Kellman says:

    Sweet, used the sideloaded settings that Kanedo posted and got my dell mini BT mouse connect, it works as I have seen the USB mouse work on Fire TV

  8. Kk says:

    I can pair a geeenthrottle controller to the firetv stick with the settings.apk but not to the actual firetv box. Why not? Is it not the same operating system?


  9. Ray says:


    I’m able to connect devices via BT, but they’re too laggy for the particular Steam games I want to play. (You can play Steam games by sideloading the OnLive app ( and linking your Steam account. They’ve got about 85 Steam games enabled so far. ( , filter by “CloudLift”) Here’s someone’s demo of that: )

  10. J Tran says:

    While at a hotel. I tried to connect to their wifi and also my new Bluetooth keyboard. While in the setting.apk, instead of clicking the search device, I accidentally turned off the Bluetooth. Now I can’t connect wifi because it is stuck on the hotels wifi and the remote does not work. I can’t control using the iPhone app not adb. Did I brick my firetv stick?

    • J Tran says:

      I meant I can’t control using iPhone remote app nor adb because I can’t connect to wifi.

      • G-rant says:

        Maybe try plugging in a network cable. Hopefully the fire will connect to your network. Your router should show the IP’s being used. Good luck.

      • Jon says:

        Can you re-name your router to the same name as the hotel’s wifi? If that doesn’t work, you can go one step further and use something like Kali Linux (backtrack) to do a MITM attack against your FireTV Stick & hopefully change the settings that way. (never had to do it myself, but it’s one of those things that sounds good in theory…)

        • Steve bond says:

          If you have a hdmi port on your to that also does cec then you can use your TV remote to access firetv stick and restore device. That’s what I had to do. And I’m all fine again now

  11. iceweasel says:

    Has anyone tried to connect up a Ethernet USB adapter to the stick? The device I’m trying to get working is the Smays 5-Pin Micro-USB to RJ45 with Hub. My biggest question is how to insert power so the stick is powered? I think the power for the hub won’t flow back to the host device. So I’d need to wire in the 5V supply on the cable connected to the stick, or split find a micro-usb splitter with 2-female micro jacks but I haven’t found one of those yet.

  12. xnamkcor says:

    Have you tried the method I used for my Chromecast?

    Plug Powered USB Hub into Power Adapter via AC
    Plug USB Hub into OTG Cable
    Plug OTG Cable into Chromecast
    (At this point the Chromecast LED lit up and booted)
    Plug USB Ethernet Adapter into USB Hub
    Plug Ethernet line into USB Ethernet Adapter
    (At this point the USB Ethernet Adapter’s RJ45 jack started blinking)

    When I checked my DHCP enabled router for “Attached Devices”, the Chromecast showed up under “Wired”.
    To “make sure”, I disabled my wireless radios on both of my routers supplying WiFi.
    It seemed not to work for a bit, but after waiting(and realising I could not push a YouTube video from my Android when my WiFi radios were off), and pushing a video from my Laptop, it seemed to start working.

  13. Edwin says:

    With all the updates that have happened since the original post tried getting USB ports to be added to the Fire TV Stick, has anyone else tried and succeeded? If you have, let us know what setup you used.

  14. Redx says:

    I know this is old post but has this changed up to today ?

Leave a Reply

Your email address will not be published. Required fields are marked *


Get AFTVnews articles in your inbox!

Get an email anytime a new article is published.
No Spam EVER and Cancel Anytime.