Kodi version 17.5.1 released with crash fix for Fire TV and Android devices

The Kodi Team has just released a new 17.5.1 version that fixes the issues that were causing version 17.5 to crash on some Fire TV and Android devices. It turns out the issues were related to changes made to joystick support on Android devices. One reader affected by the issue has confirmed that updating from 17.5 to 17.5.1 on their Fire TV has fixed the issue.

Whether you had issues with version 17.5 or not, you don’t have to uninstall or downgrade version 17.5 before installing version 17.5.1. If you haven’t installed version 17.5 at all, you should skip it and install the new 17.5.1 version.

If you’re using my Downloader app, simply enter bit.ly/kodi1751 into the URL field and the new 17.5.1 version will download and install. If you have a Fire TV 2 or 3 and prefer using the 64-bit version of Kodi, enter bit.ly/kodi641751 into the URL field of my Downloader app.

ShareTweetShare+1

53 comments
  1. AFTVnews says:

    If you have issues downloading the app using the bit.ly URLs provided above, try:
    32-bit: bit.ly/kodi1751mirror
    64-bit: bit.ly/kodi641751mirror

    • achilles1001 says:

      Which version 32 or 64 bit should be used for each device? It has been several years since I updated my devices. I have ftv box gen 1, gen 2, and ftv stick gen 1 and gen 2.

      • Ed Miller says:

        Always use the 32bit. No one uses the 64bit

        • AdviceGiver says:

          That’s wrong advice.

          Use the arm64bit versions for Fire TV 2, New Fire TV and Fire TV Stick

          Use arm (32bit) for Fire Stick (original version) and Fire TV (Original version)

        • Bill says:

          Not true. All of my AFTV box have 64bit installed. Everyone that I have built has 64 bit installed. Your statement is not true. Should be careful about advice. A lot of people use the 64bit version. It has advantages and a lot more robust than 32 bit. If you are using gen 1 fire tv box or any firestick prior to gen 3, then using 32 bit is advisable, but Gen 2 and later, 64 bit is best.

        • Bruce says:

          Then why is there a 64bit?

    • Mr. Chungo says:

      I have a 2nd gen firestick and have tired all the links above and I can’t seem to upgrade from 17.5 to 17.5.1. Any work around would be great.

  2. gen1aftv says:

    17.5.1 is working for me, 17.5 did not.

  3. Mike says:

    How do you do this on android tv

  4. Keith says:

    Maybe it’s just me but I wish I had avoided this update. This afternoon I updated to 17.5 and got the crash on launch. So I wound up deleting my sources and starting from scratch and that fixed it.
    Then I saw there was 17.5.1 so I installed it for my other AFTV. Now it keeps freezing whenever I try to update the library.
    17.4 was working fine for me. I shouldve left it alone.
    Anyways it could be an anomally but if youre generally happy Id wait to update.

    • Ed Miller says:

      Yes Keith you should of left it alone. Try a re-set to factory…(you will lose all old info) Then Install the new 17.5.1…

  5. Brian P Cook says:

    I followed the instructions and tried this at least 10 times and I keep getting a message saying app not installed.

  6. Kelly Breau says:

    Omg..thank you this saved me!

  7. Lobo Lansky says:

    Android tv already has google app store in it just update kodi from it. I did.

  8. Drake Griffin says:

    I was able to use 17.5 just fine on my second gen stick but I’m gonna try this one because it’s newer. I don’t see it on the kodi website though is this official? Also what is the advantage of the 64bit… I know the stick will not run it but is there any advantage to using 64bit kodi over 32bit on a more powerful device like the 2nd gen box or possibly the 3rd gen.

  9. Craig says:

    I’ve just tried to install on my new Fire TV 3,but get a message “no app found to handle this file” after I click install (the 64 bit). Any idea why?

  10. John says:

    Yep, you fix worked for me, used your download app and Kodi 15.5.1 was installed.
    Thanks

  11. Drake Griffin says:

    In this version 17.5.1 it is still listed as 17.5 (even in the device settings)….. Still a bit mystified as to the origins of this new version. Although i’ve had no problems with either version.

  12. Rich says:

    Got my new Fire TV today I downloaded th Downloader app on to it and was able to download the new kodi 17.51 on to it but cannot install it I keep getting this message “No app found to handle this file” I then download Kodi 17.5 and 17.4 I am getting the same message from all 3 files. Is there something different I have to do with the New Fire TV that came out today ? I was able to download and install 17.4 a few days ago on the New Firestick without any issues.

  13. Tony says:

    Got that same message for both versions still any luck anyone?

  14. Sloth says:

    Does anyone have a problem installing kodi on the fireTv version gen.3

  15. Rich says:

    see this thread, there is a fix which I did not try yet.
    http://www.aftvnews.com/the-amazon-fire-tv-3-has-arrived/

  16. WizeGuy says:

    Sports devil does not work anymore. Whats the best sports app?

  17. Will says:

    Kodi crashes and goes back to firestick home page after about 10 mins of watching anything on 17 .3 and 4 and 5 I’m on 17.51 or so I thought it says 17.5 on kodi load up page any help pls

  18. Beginner says:

    Hi folks,
    To download Kodi for the 1st time I’ve tried “bit.1y/kodi641751” in browser a few time to no avail. It keeps giving me “webpage not available”! !
    Do I need to have www In front & .com at the end of it?
    It’s a bit frustrating

  19. David walker says:

    I have the 17.5.1 installed but when I have auto resolution up to 4k the video playback is choppy and not smooth
    Any help appreciated

  20. Dirk says:

    On my android box i still got the message .. Kodi Isnt responding ..after the 17.5.1 update…please fix this …

  21. Nati Eitan says:

    Both 17.5 and 17.5.1 crash on my Android device

  22. Chris says:

    Hi ever since I updated to Kodi 17.5 on my Sony Android to a week last Monday it no longer works. It says that Kodi amended it to a 17.5.1 version and that those using Google Playstore would automatically be updated…..this has not happened at all and I have tried finding Kodi Support contact numbers….email support….and even tried paying for a one off online web help…..none of these are any good. I have spent days trying to get help…..I have uninstalled and reinstalled my Kodi App in the hope but nothing. I have spent a lot of time on the phone to Google Playstore Support who say it is not down to them but the developers of Kodi…XMBC…evidently they send updates out in batches?????? I have never experienced problems before and am so upset. CAN SOMEONE PLEASE HELP

  23. Kary Long says:

    I recently loaded 17.5.1 on my 1st Gen Fire Tv Box and now it’s Bricked! It won’t load the main Amazon Interface to even select Kodi, uninstall Kodi, reset to Factory default or anything. If i upplug the unit, it will show the Amazon logo, then the screen goes blank and the light on the front of the unit slowly goes in and out. Any suggestions?

  24. kralj says:

    My Amazon fire tv 3gen is not compatible with kodi 64bit apps,hm why :) ?

  25. Wayne Gladin says:

    If you are considering buying an AFTV AND using Kodi Krypton AND you are going to be using audio passthrough, then I’d really suggest you read at least the first post in this thread before buying: https://forum.kodi.tv/showthread.php?tid=289735

    Don’t shoot the messenger…

Leave a Reply to Chris Cancel reply

Your email address will not be published. Required fields are marked *

*

Get notified of new posts

Enter your email address to receive notifications of new posts by email.