How to install and setup Xposed Framework on the Amazon Fire TV

xposed-logo
The Xposed framework is a platform which allows for the installation of modules which change the behavior of the Amazon Fire TV. By itself, the Xposed framework does not do anything. The modules installed once the framework is setup are the ones that can modify the behavior of the Fire TV. Installation of Xposed requires that your Fire TV is rooted. This guide will walk you through the simple steps of installing and setting up Xposed. Future guides will discuss the installation of modules and what can be done with Xposed.

  1. The Xposed Framework requires root, so if your Fire TV is not rooted, you should first follow my Rooting Starters Guide and root your Fire TV.
  2. Download the latest Xposed APK from here. The download link should be about half way down the page labeled “de.robv.android.xposed.installer_v##_#####.apk”
    xposedinstall-01
  3. Sideload the Xposed Framework onto your Fire TV
  4. Launch “Xposed Installer” on the Fire TV from the Settings > Applications menu
    firetvscreenshot_20140621-130552
  5. Select “Framework”
    firetvscreenshot_20140621-131659
  6. Select “OK” to dismiss the popup
    firetvscreenshot_20140621-131910
  7. Select “Install/Update” to install the framework
    firetvscreenshot_20140621-132033
  8. Select “Grant” on the SuperSU popup
    firetvscreenshot_20140621-132104
  9. Select “OK” to reboot
    firetvscreenshot_20140621-132228

ShareTweetShare+1

12 comments
  1. Josh says:

    You spelled SuperSU wrong in Step 8. No biggie, just letting you know.

  2. Joshi says:

    Some Xposed modules has caused boot loop issues before on other devices.

    Would be nice if there is some pointers on how to recover from bootloop if that should happen on Fire TV.

  3. Kyle says:

    I dont get the the walpaper zip file when im in the reflux app

  4. Lee says:

    Can we doe load this into the new aftv 2?

  5. Lee says:

    Sorry, side load onto new aftv ?

  6. jim says:

    Hi i have rooted my AFTV second generation. After i installed xposed (latest version), i couldn’t install framework as the error is “xposed is not (yet) compatible with ANdroid SDK version 22. Any idea? thanks

    Ace

  7. Mo says:

    I installed xposed-v80-sdk22-arm64 zip through twrp recovery, and XposedInstaller_3.0_alpha4.apk through adbfire. I also sideloaded HDXPosed, and checked 1.3. On step # 7 where we select install/update through the framework, nothing happens.
    Any suggestions? Thanks

  8. Christopher Loughrey says:

    It says it’s not compatible with Android version 22 or your processor (arm64-v8a) for Fire TV 2. Is there a version that actually works? This guide hasn’t been updated since Amazon moved to Lollipop which Xposed is not compatible with. Any alternative to getting Rbox’s mods?

  9. Jack Simore says:

    Hi. I was wondering if i did this on a fire tv stick would i get bricked or would it not brick i want to install Google Play store on my fire tv stick. Is this possible to do

Leave a Reply

Your email address will not be published. Required fields are marked *

*