How to clear Kodi’s “first run help” screen on the Amazon Fire TV and Fire TV Stick


If you’ve sideloaded the latest version of Kodi on an Amazon Fire TV or Fire TV Stick recently, you may have run into a little quirk that causes the “first run help” dialogue to appear everytime you launch the app, even though it’s not the first time you’ve run it. This is one of those things that I’ve personally experienced, but never got to the bottom of, because it eventually seems to just work itself out. Thanks to reddit user kilnvideo, I now know the cause and the easy fix. If you always leave Kodi by pressing the Home or Back button on your remote, and never properly exit the app, it never gets a chance to record that you’ve launched it at least once. So the way to get the “first run help” message to never appear again is to simply exit Kodi properly, by using the power icon in the lower left of the Kodi home screen, at least once.


  1. FireKodi says:

    buy using the power icon in the lower left … Typo, should be by using.

  2. natebetween says:

    Pointing out typos really adds to the conversation! Thanks!!

    As for the actual article…thank you, Elias. This has been driving me nuts. It’s not a big deal, but it’s an annoyance for sure.

    Your number won in my book, and thats all their is two it!

  3. tech3475 says:

    Weird, unless it’s a version I’ve not used I’ve never had this issue and I only ever leave using the home button.

    Not unless because I then usually do something else e.g. add a NAS share it is able to save during that period.

  4. Cyclone says:

    Well that is great But my biggest problem I am having with Kodi on fire tv is I can not get it to close with exit. I have to close with home button. The exit of Kodi just hangs with the exit screen and will not go back. Is there a fix for this problem?

  5. granman says:

    As usual you are THE place to get helpful FTV hints. I haven’t upgraded any of the 5 we have in the house, they’re all still running 15.1 (yep I know I’m slow, but hey, I have to upgrade 5 of them). I do have a question, is this for the Jarvis 16.x (current stable version or all of them) or is this bug for the new new new Krypton betas 17.x?

Leave a Reply

Your email address will not be published. Required fields are marked *