Amazon’s Alexa app drops support for Android 4.x and iOS 8 devices

Amazon has just updated their Alexa app compatibility page and changed the minimum Android version from 4.4 to 5.0 and the minimum iOS version to 9.0. The iOS minimum requirement is already in place in the iTunes Appstore, but the Android minimum version is still set to 4.4 in the Google Play Store. This could indicate even more major updates are on the horizon for the Alexa app, since bumping up the minimum OS requirement usually means a feature is being added that requires new hardware and APIs.

The Alexa app just went through a major update when Amazon released calling and messaging capabilities for their Echo line of devices. Those new calling and messaging features, including video calls, are usable through the Alexa app, and have made it a competitor to behemoths like Skype, WhatsApp, and Facebook Messenger.

Amazon’s Alexa app is quickly gaining ground as one of their most installed apps. It has surpassed 5 million installs in the Google Play Store, making it roughly as popular as the Fire TV Remote app.

The new minimum requirements for the Alexa app roughly exclude phones that are 4 or 5 years old and older. That means the iPhone 4S, Nexus 4, and Galaxy S4 can still run the app, but not the iPhone 4, Galaxy Nexus, and Galaxy S3. Those who don’t have a newer device that meats the new minimum requirements can still use the Alexa web portal to configure their devices, but newer features, like calling and messaging, are not available through that website.

ShareTweetShare+1

One comment
  1. Ujn Hunter says:

    Can you still use the Alexa App that is compatible with your phone? i.e. You can’t get the most recent update, but the App version already installed should still function, no?

Leave a Reply

Your email address will not be published. Required fields are marked *

*

Get notified of new posts

Enter your email address to receive notifications of new posts by email.